What technical characteristics should my mobile device have to run Lykke Wallet?

To run Lykke Wallet application on your iOS device, you need iOS version 10.0 or above. The application is compatible with iPhone, iPad, and iPod touch.
To run Lykke Wallet application on your Android device, you need Android version 5.1.1 or above. The application is compatible with Android phones and tablets.

In Lykke we are committed to always offering the highest quality level of service and security to our users.
In accordance with this commitment and to streamline efforts into the latest and most secure software, Lykke stops supporting the following mobile OS versions:

  • IOS 8, IOS 9
  • Android 5.1.0 and all earlier versions.
Have more questions? Submit a request

0 Comments

Article is closed for comments.